summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-11 19:44:46 (GMT)
committerBrad King <brad.king@kitware.com>2014-12-11 19:50:52 (GMT)
commit9cd30fb0f554fd22ea98a59dd1abadd35804f754 (patch)
treefc637ef260e93e7c8543c9c5624fb27970d3d388 /test/CMakeLists.txt
parent6feeb4e7dfb7cf79fadc06f9184924810668110a (diff)
downloadCastXML-9cd30fb0f554fd22ea98a59dd1abadd35804f754.zip
CastXML-9cd30fb0f554fd22ea98a59dd1abadd35804f754.tar.gz
CastXML-9cd30fb0f554fd22ea98a59dd1abadd35804f754.tar.bz2
Output: Fix references to cv-qualified types encountered indirectly
Teach AddDumpNode to optionally report back the actual QualType that it selects after possibly unwrapping some layers of indirection in the Clang AST. Use this in GetTypeIdRef so that we check this actual QualType's cv qualifiers instead of the original QualType. Otherwise we may generate a dangling reference to the id number that is replaced by a CvQualifiedType id. Fix the expected output of existing test cases that exhibit this problem and add a new test case designed to cover the behavior explicitly.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 5978260..fd666b6 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -159,6 +159,7 @@ castxml_test_gccxml(Class-template-Method-Argument-default)
castxml_test_gccxml(Class-template-bases)
castxml_test_gccxml(Class-template-friends)
castxml_test_gccxml(Class-template-member-Typedef)
+castxml_test_gccxml(Class-template-member-Typedef-const)
castxml_test_gccxml(Class-template-member-template)
castxml_test_gccxml(CvQualifiedType)
castxml_test_gccxml(Enumeration)