summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-06-08 16:51:05 (GMT)
committerBrad King <brad.king@kitware.com>2015-06-08 16:51:05 (GMT)
commitad7f0dc7df8ed8ea32498a61d64dce0024478c00 (patch)
tree13b6f26fb946bb7ef2f943cb784cea2698c3bd65 /test/CMakeLists.txt
parentc97aef7dd5919db271fdf4d6abe7419a2105bbbd (diff)
downloadCastXML-ad7f0dc7df8ed8ea32498a61d64dce0024478c00.zip
CastXML-ad7f0dc7df8ed8ea32498a61d64dce0024478c00.tar.gz
CastXML-ad7f0dc7df8ed8ea32498a61d64dce0024478c00.tar.bz2
test: Add infrastructure for custom test input and start options
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 763c7a7..afbbbaf 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -34,10 +34,21 @@ macro(castxml_test_cmd test)
endmacro()
macro(castxml_test_gccxml_common prefix ext std test)
+ if(castxml_test_gccxml_custom_start)
+ set(_castxml_start ${castxml_test_gccxml_custom_start})
+ else()
+ set(_castxml_start --castxml-start start)
+ endif()
+ if(castxml_test_gccxml_custom_input)
+ set(_castxml_input ${castxml_test_gccxml_custom_input})
+ else()
+ set(_castxml_input ${test})
+ endif()
set(command $<TARGET_FILE:castxml>
- --castxml-gccxml --castxml-start start
+ --castxml-gccxml
+ ${_castxml_start}
-std=${std}
- ${CMAKE_CURRENT_LIST_DIR}/input/${test}.${ext}
+ ${CMAKE_CURRENT_LIST_DIR}/input/${_castxml_input}.${ext}
-o ${prefix}.${std}.${test}.xml
${castxml_test_gccxml_extra_arguments}
)