summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-31 20:22:27 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-01 13:50:56 (GMT)
commitb88536173b6ca2e79d8837bed62b9452920a319e (patch)
tree18e020e333dedfdff1b7e00ea52ca31a0266174a /test/CMakeLists.txt
parent9b059184628f1d7dea927a6f08a3ac70f8036da4 (diff)
downloadCastXML-b88536173b6ca2e79d8837bed62b9452920a319e.zip
CastXML-b88536173b6ca2e79d8837bed62b9452920a319e.tar.gz
CastXML-b88536173b6ca2e79d8837bed62b9452920a319e.tar.bz2
castxml: Report help with '-help' and '--help'
Also pass the flag through so Clang reports its help too.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6d3d8a9..19c00dc 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -63,6 +63,8 @@ set(empty_cxx ${input}/empty.cxx)
set(empty_m ${input}/empty.m)
set(empty_mm ${input}/empty.mm)
+castxml_test_cmd(help1 -help)
+castxml_test_cmd(help2 --help)
castxml_test_cmd(no-arguments)
castxml_test_cmd(version --version)