summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-21 17:23:33 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-24 18:19:04 (GMT)
commitbeea56e5aedd3b41a674d6ea548d34d428fa2678 (patch)
tree2d54d4c89f40b63a62fbd738b7a3b969efb1771c /test/CMakeLists.txt
parent5ba34a458bb4ba183f2081956bc27aa0e520d781 (diff)
downloadCastXML-beea56e5aedd3b41a674d6ea548d34d428fa2678.zip
CastXML-beea56e5aedd3b41a674d6ea548d34d428fa2678.tar.gz
CastXML-beea56e5aedd3b41a674d6ea548d34d428fa2678.tar.bz2
Output: Drop from Namespace members="" non-inline class members
Clang presents non-inline class members in the list of declarations in a namespace. Teach PrintMembersAttribute to skip declarations whose actual context is not the context that listed them.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index c73186e..b406172 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -118,6 +118,9 @@ castxml_test_gccxml(Method)
castxml_test_gccxml(MethodType)
castxml_test_gccxml(MethodType-cv)
castxml_test_gccxml(Namespace)
+castxml_test_gccxml(Namespace-Class-members)
+castxml_test_gccxml(Namespace-Class-template-members)
+castxml_test_gccxml(Namespace-Function-template-members)
castxml_test_gccxml(OffsetType)
castxml_test_gccxml(OffsetType-cv)
castxml_test_gccxml(OperatorFunction)