summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-03-23 17:36:21 (GMT)
committerBrad King <brad.king@kitware.com>2015-03-23 17:38:28 (GMT)
commitd687d1d00346d81cf51bc9eb177d1c090b608bbe (patch)
tree2d06ac9366a70de9c4f016f719fbdb7e87c4d9c9 /test/CMakeLists.txt
parent94256f359999905034ff0065b2a7627348c35220 (diff)
downloadCastXML-d687d1d00346d81cf51bc9eb177d1c090b608bbe.zip
CastXML-d687d1d00346d81cf51bc9eb177d1c090b608bbe.tar.gz
CastXML-d687d1d00346d81cf51bc9eb177d1c090b608bbe.tar.bz2
Output: Traverse namespace redeclarations
A namespace may be redeclared to add more members: namespace ns { void f1(); } namespace ns { void f2(); } Fix our AST traversal to consider members from all redeclarations of each namespace instead of only the canonical (first) one. Previously we generated members from later redeclarations only if they were referenced from other declarations we happened to encounter. Reported-by: Michka Popoff <michkapopoff@gmail.com>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 9febe91..aa0a2fa 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -191,6 +191,8 @@ castxml_test_gccxml(Namespace-Class-template-members)
castxml_test_gccxml(Namespace-Function-template-members)
castxml_test_gccxml(Namespace-empty)
castxml_test_gccxml(Namespace-extern-C-members)
+castxml_test_gccxml(Namespace-repeat)
+castxml_test_gccxml(Namespace-repeat-start)
castxml_test_gccxml(OffsetType)
castxml_test_gccxml(OffsetType-cv)
castxml_test_gccxml(OperatorFunction)