summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-02-26 20:34:24 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-21 21:04:46 (GMT)
commitfa551b8b9703c5877ac653344c3e01b2ef4de98b (patch)
tree8066e1ef2b28de78ea8d04cce4300b1ab23d19e8 /test/CMakeLists.txt
parent556f3cb3e00dacea207124a1c954187d6ccb3b95 (diff)
downloadCastXML-fa551b8b9703c5877ac653344c3e01b2ef4de98b.zip
CastXML-fa551b8b9703c5877ac653344c3e01b2ef4de98b.tar.gz
CastXML-fa551b8b9703c5877ac653344c3e01b2ef4de98b.tar.bz2
Output: Generate function template instantiations and specializations
Teach the AddStartDecl and PrintMembersAttribute methods to queue function template instantiations and specializations for output using an AddFunctionTemplateDecl helper to share common implementation. Map the Clang SubstTemplateTypeParm type to its replacement type.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 815060f..50c8343 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -72,6 +72,7 @@ castxml_test_gccxml(Class-incomplete)
castxml_test_gccxml(Class-template)
castxml_test_gccxml(CvQualifiedType)
castxml_test_gccxml(Function)
+castxml_test_gccxml(Function-template)
castxml_test_gccxml(Function-throw)
castxml_test_gccxml(FundamentalType)
castxml_test_gccxml(Method)