summaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-02-24 21:23:45 (GMT)
committerBrad King <brad.king@kitware.com>2015-02-25 13:41:56 (GMT)
commitfe1bb977eef136daecec0d5717fbd7379f139e8a (patch)
treef0ef6ac508a4d0c664c7d941baca54431e84ca37 /test/CMakeLists.txt
parent798eeb5e1c15251ab4f82dc754f6ef62d455f746 (diff)
downloadCastXML-fe1bb977eef136daecec0d5717fbd7379f139e8a.zip
CastXML-fe1bb977eef136daecec0d5717fbd7379f139e8a.tar.gz
CastXML-fe1bb977eef136daecec0d5717fbd7379f139e8a.tar.bz2
Detect: Provide __float128 when simulating GNU compilers
GNU compilers provide a __float128 builtin type on Intel architectures. When simulating such GNU compiler preprocessing, define a __float128 type with the expected size and alignment in case the translation unit references it.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1430dca..9febe91 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -259,10 +259,12 @@ endforeach()
if(TEST_GNU_C)
set(castxml_test_gccxml_extra_arguments --castxml-cc-gnu ${TEST_GNU_C})
+ castxml_test_gccxml_c(GNU-float128)
unset(castxml_test_gccxml_extra_arguments)
endif()
if(TEST_GNU_CXX)
set(castxml_test_gccxml_extra_arguments --castxml-cc-gnu ${TEST_GNU_CXX})
+ castxml_test_gccxml(GNU-float128)
unset(castxml_test_gccxml_extra_arguments)
endif()