summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <doxygen@gmail.com>2020-06-13 18:45:58 (GMT)
committerDimitri van Heesch <doxygen@gmail.com>2020-06-13 18:45:58 (GMT)
commit07dd4ae9033c9872d70d68ff1d83ec46f1db7cb4 (patch)
tree97a65942643388ec3bb349912698c0d346c1fba6 /CMakeLists.txt
parentfa4e3f5f955e602f02545e049361510f3334cfff (diff)
downloadDoxygen-07dd4ae9033c9872d70d68ff1d83ec46f1db7cb4.zip
Doxygen-07dd4ae9033c9872d70d68ff1d83ec46f1db7cb4.tar.gz
Doxygen-07dd4ae9033c9872d70d68ff1d83ec46f1db7cb4.tar.bz2
Add options to enable various sanitizers
New CMAKE options (default OFF): - SANITIZE_ADDRESS:BOOL=OFF - SANITIZE_LINK_STATIC:BOOL=OFF - SANITIZE_MEMORY:BOOL=OFF - SANITIZE_THREAD:BOOL=OFF - SANITIZE_UNDEFINED:BOOL=OFF
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16c0454..88b99d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,6 +31,7 @@ option(enable_coverage "Enable coverage reporting for gcc/clang [development]" O
SET(enlarge_lex_buffers "262144" CACHE INTERNAL "Sets the lex input and read buffers to the specified size")
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/Sanitizers")
set(TOP "${CMAKE_SOURCE_DIR}")
include(version)
@@ -102,6 +103,7 @@ if (BISON_VERSION VERSION_LESS 2.7)
message(SEND_ERROR "Doxygen requires at least bison version 2.7 (installed: ${BISON_VERSION})")
endif()
find_package(Threads)
+find_package(Sanitizers)
if (sqlite3)
find_package(SQLite3 REQUIRED)