summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 10:25:29 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 18:25:40 (GMT)
commit28f09783b1e45a827729abaca61f963dd869381b (patch)
tree17b6c46b4c2a495b625d534638114c98d37d4d90 /CMakeLists.txt
parent0d7be027a6fea2ac198dded58f8b55cda1bbe962 (diff)
downloadDoxygen-28f09783b1e45a827729abaca61f963dd869381b.zip
Doxygen-28f09783b1e45a827729abaca61f963dd869381b.tar.gz
Doxygen-28f09783b1e45a827729abaca61f963dd869381b.tar.bz2
CMake: remove CUSTOM_(LINK|INCLUDE)_DIR
When some header or library is not found introduce a proper find_* call for it and use the results. Especially injecting additional link directories would just confuse the automatic library ordering done by CMake and is basically never the right solution for any link problem.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 79a53e7..ab58531 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,8 +99,6 @@ set(ENV{DOXYGEN_DOCDIR} ${DOXYDOCS})
set(GENERATED_SRC "${CMAKE_BINARY_DIR}/generated_src" CACHE INTERNAL "Stores generated files")
set(LIBRARY_OUTPUT_PATH ${PROJECT_BINARY_DIR}/lib)
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_BINARY_DIR}/bin)
-set(CUSTOM_INCLUDE_DIR "" CACHE FILEPATH "Extra include path")
-set(CUSTOM_LINK_DIR "" CACHE FILEPATH "Extra library path")
# place binaries for all build types in the same directory, so we know where to find it
# when running tests or generating docs
@@ -123,14 +121,6 @@ else ()
endif()
set(LANG_CODES ${lcodes} CACHE STRING "List of language codes for which translations should be compiled in")
-if (CUSTOM_INCLUDE_DIR)
- include_directories(${CUSTOM_INCLUDE_DIR})
-endif()
-
-if (CUSTOM_LINK_DIR)
- link_directories(${CUSTOM_LINK_DIR})
-endif()
-
if (win_static)
set(CompilerFlags
CMAKE_CXX_FLAGS