summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralex85k <alex85k@github.com>2015-10-28 13:40:02 (GMT)
committeralex85k <alex85k@github.com>2015-10-28 13:40:02 (GMT)
commit3d684f6d123abdbf630bb19bc6095cc9d69efb68 (patch)
tree1fb48d932cc7a10ef93e449f8685ddcc538ca9c8 /CMakeLists.txt
parent3a318681dc497127ebebd38a20a537c5dff74cc0 (diff)
downloadDoxygen-3d684f6d123abdbf630bb19bc6095cc9d69efb68.zip
Doxygen-3d684f6d123abdbf630bb19bc6095cc9d69efb68.tar.gz
Doxygen-3d684f6d123abdbf630bb19bc6095cc9d69efb68.tar.bz2
allow building with custom iconv on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fb1e94c..a020f41 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,9 @@ if (${CMAKE_SYSTEM} MATCHES "Darwin")
endif()
if (WIN32)
- set(ICONV_DIR "${CMAKE_SOURCE_DIR}/winbuild")
+ if(NOT ICONV_DIR)
+ set(ICONV_DIR "${CMAKE_SOURCE_DIR}/winbuild")
+ endif()
set(CMAKE_REQUIRED_DEFINITIONS "-DLIBICONV_STATIC")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj") # needed for language.cpp on 64bit
add_definitions(-DLIBICONV_STATIC -D_CRT_SECURE_NO_WARNINGS)