summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Niebler <eniebler@boost.org>2019-09-10 17:48:55 (GMT)
committerGitHub <noreply@github.com>2019-09-10 17:48:55 (GMT)
commit64f1f2357ae764f2c8190d067aff801bc0a56721 (patch)
tree2bde7fee582c36e1587980ae67b98ee2966c1253 /CMakeLists.txt
parent81da20ff839843634ee6db5f517bfcb7ef87d4b9 (diff)
downloadDoxygen-64f1f2357ae764f2c8190d067aff801bc0a56721.zip
Doxygen-64f1f2357ae764f2c8190d067aff801bc0a56721.tar.gz
Doxygen-64f1f2357ae764f2c8190d067aff801bc0a56721.tar.bz2
Latest libclang needs C++14
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7aa1c01..2644ceb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,8 +49,8 @@ if (use_libclang)
endif()
endif()
-# use C++11 standard for compiling (libclang option requires it)
-set(CMAKE_CXX_STANDARD 11)
+# use C++14 standard for compiling (libclang option requires it)
+set(CMAKE_CXX_STANDARD 14)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS ON)