summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2017-02-19 10:50:12 (GMT)
committerGitHub <noreply@github.com>2017-02-19 10:50:12 (GMT)
commit736cb284b90bf66e514cbb2b73035fd9217488c0 (patch)
tree312b1946856317bea14c3a8966a1c565c12ac3a1 /CMakeLists.txt
parent9e3031e5f448a91fd68f1e9753e6f7beceffc0a1 (diff)
parent82dbb5fe863e13175eda130dcc728b102101ccda (diff)
downloadDoxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.zip
Doxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.tar.gz
Doxygen-736cb284b90bf66e514cbb2b73035fd9217488c0.tar.bz2
Merge pull request #425 from analizo/doxyparse
new addon doxyparse, a source parsing engine
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4c55859..6127de2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ project(doxygen)
option(build_wizard "Build the GUI frontend for doxygen." OFF)
option(build_app "Example showing how to embed doxygen in an application." OFF)
+option(build_parse "Parses source code and dumps the dependencies between the code elements." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
option(build_doc "Build user manual" OFF)
@@ -141,6 +142,7 @@ add_subdirectory(doc)
add_subdirectory(addon/doxmlparser)
add_subdirectory(addon/doxyapp)
+add_subdirectory(addon/doxyparse)
add_subdirectory(addon/doxysearch)
add_subdirectory(addon/doxywizard)