summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 10:31:29 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 18:25:40 (GMT)
commit7c1c75a2c5583415d178e0e46a1a356bef9b0c84 (patch)
tree305f101e105276db4a507171173fe478d67154fb /CMakeLists.txt
parentac5ca4ef86ad50232be75a65fab99302307b7795 (diff)
downloadDoxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.zip
Doxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.tar.gz
Doxygen-7c1c75a2c5583415d178e0e46a1a356bef9b0c84.tar.bz2
CMake: avoid if() around the whole contents of plugin CMakeLists.txt
Just don't call add_subdirectory() if the build flag is not set.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ab58531..4be77e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -146,11 +146,7 @@ add_subdirectory(src)
add_subdirectory(examples)
add_subdirectory(doc)
-add_subdirectory(addon/doxmlparser)
-add_subdirectory(addon/doxyapp)
-add_subdirectory(addon/doxyparse)
-add_subdirectory(addon/doxysearch)
-add_subdirectory(addon/doxywizard)
+add_subdirectory(addon)
enable_testing()
add_subdirectory(testing)