summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel G <nwrkbiz@users.noreply.github.com>2020-12-09 21:28:12 (GMT)
committerGitHub <noreply@github.com>2020-12-09 21:28:12 (GMT)
commit7eff1f27f6edd509f2c5c472cd76d13691cd437a (patch)
tree9c5dfa5abebb94b688e153bcdf203e76b3be90a7 /CMakeLists.txt
parent979ea243de83a693e0d9da545ee4cbe7db9521ee (diff)
downloadDoxygen-7eff1f27f6edd509f2c5c472cd76d13691cd437a.zip
Doxygen-7eff1f27f6edd509f2c5c472cd76d13691cd437a.tar.gz
Doxygen-7eff1f27f6edd509f2c5c472cd76d13691cd437a.tar.bz2
Update CMakeLists.txt
Update CMakeLists.txt to allow cross compiling on Linux for Windows. Pass -DCMAKE_CXX_FLAGS="$(CXXFLAGS) -DCYGWIN=1" to cmake so right PRETTY_FUNC is used in markdown.cpp when -DWIN32 is set somewhere else. Pass -DCMAKE_EXE_LINKER_FLAGS="$(LDFLAGS) -Wl,--whole-archive -liconv -Wl,--no-whole-archive" (and make sure win-iconv is in library search path. https://github.com/win-iconv/win-iconv)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe0ab42..06b9696 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,7 +69,8 @@ endif()
if (WIN32)
if ((NOT CMAKE_GENERATOR MATCHES "MinGW Makefiles") AND
- (NOT CMAKE_GENERATOR MATCHES "MSYS Makefiles"))
+ (NOT CMAKE_GENERATOR MATCHES "MSYS Makefiles") AND
+ (NOT CMAKE_GENERATOR MATCHES "Unix Makefiles"))
if (NOT ICONV_DIR)
set(ICONV_DIR "${PROJECT_SOURCE_DIR}/winbuild")
endif()