summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDimitri van Heesch <dimitri@stack.nl>2017-08-20 09:18:21 (GMT)
committerDimitri van Heesch <dimitri@stack.nl>2017-08-20 09:18:21 (GMT)
commitb0aae61c97966cb9d424b500d7ced5bdf500d8db (patch)
tree467f8a07e0757e0658de96bb37101b8c065f6359 /CMakeLists.txt
parent82221a3a3f20f7e7cef94b52ac6c575f940b51f3 (diff)
downloadDoxygen-b0aae61c97966cb9d424b500d7ced5bdf500d8db.zip
Doxygen-b0aae61c97966cb9d424b500d7ced5bdf500d8db.tar.gz
Doxygen-b0aae61c97966cb9d424b500d7ced5bdf500d8db.tar.bz2
Fixes for cross platform build with new LLVM/CLANG version
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8337d4..ed63320 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,8 @@ endif()
set(MACOS_VERSION_MIN 10.5)
if (use_libclang)
set(clang "1" CACHE INTERNAL "used in settings.h")
- find_package(LibClang REQUIRED)
+ find_package(LLVM CONFIG REQUIRED)
+ find_package(Clang CONFIG REQUIRED)
if (${CMAKE_SYSTEM} MATCHES "Darwin")
set(MACOS_VERSION_MIN 10.11)
endif()