summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoenio Costa <joenio@colivre.coop.br>2015-12-13 16:10:21 (GMT)
committerJoenio Costa <joenio@colivre.coop.br>2015-12-13 16:25:58 (GMT)
commite6dcc3b6c6dd449800eeebc172c1d15367d61d74 (patch)
tree1cb9a76ae8a3545b273a3dd40103f15ec9b68dc8 /CMakeLists.txt
parenta7284cbd77518200d9cd4f5adb04cfc40f357d24 (diff)
downloadDoxygen-e6dcc3b6c6dd449800eeebc172c1d15367d61d74.zip
Doxygen-e6dcc3b6c6dd449800eeebc172c1d15367d61d74.tar.gz
Doxygen-e6dcc3b6c6dd449800eeebc172c1d15367d61d74.tar.bz2
new addon doxyparse, a source parsing engine
doxyparse parses source code and dumps the dependencies between the code elements. Today doxyparse is in use by Analizo* toolkit, a suite of source code analysis tools, aimed at being language-independent and extensible. * http://analizo.org Signed-off-by: Antonio Terceiro <terceiro@softwarelivre.org> Signed-off-by: João M. Miranda <joaomm88@gmail.com> Signed-off-by: Paulo Meirelles <paulo@softwarelivre.org> Signed-off-by: Vinicius Daros <vkdaros@mercurio.eclipse.ime.usp.br>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a020f41..666c76d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ project(doxygen)
option(build_wizard "Build the GUI frontend for doxygen." OFF)
option(build_app "Example showing how to embed doxygen in an application." OFF)
+option(build_parse "Parses source code and dumps the dependencies between the code elements." OFF)
option(build_xmlparser "Example showing how to parse doxygen's XML output." OFF)
option(build_search "Build external search tools (doxysearch and doxyindexer)" OFF)
option(build_doc "Build user manual" OFF)
@@ -133,6 +134,7 @@ add_subdirectory(doc)
add_subdirectory(addon/doxmlparser)
add_subdirectory(addon/doxyapp)
+add_subdirectory(addon/doxyparse)
add_subdirectory(addon/doxysearch)
add_subdirectory(addon/doxywizard)