summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-07-20 13:31:30 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-07-20 13:31:30 (GMT)
commitefc67de9d1a4e36ab94164352778fd19f33652b3 (patch)
tree33a72eec96c4b7470d0f40298e795589b640a186 /CMakeLists.txt
parent242abf259fcd639ebf33162b6f442c80b0fe0043 (diff)
downloadDoxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.zip
Doxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.tar.gz
Doxygen-efc67de9d1a4e36ab94164352778fd19f33652b3.tar.bz2
Option for 'input buffer overflow'
Cmake option `-Denlarge_lex_buffers=<size>` to enlarge input and read buffers for source code lexers.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7ee9d7e..69ed660 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,6 +26,8 @@ option(win_static "Link with /MT in stead of /MD on windows" OFF)
option(english_only "Only compile in support for the English language" OFF)
option(force_qt4 "Forces doxywizard to build using Qt4 even if Qt5 is installed" OFF)
+SET(enlarge_lex_buffers "262144" CACHE INTERNAL "Sets the lex input and read buffere to the specified size")
+
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
set(TOP "${CMAKE_SOURCE_DIR}")
include(version)