summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-04-07 13:10:53 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-04-07 13:10:53 (GMT)
commitfa9dda01e6c013c7fe9be99b21d8bbf3c95c0482 (patch)
tree33fb7fab952dd602aa91ba29525e749e146a3596 /CMakeLists.txt
parent16d025c8a08b485f5d43ade0986d716bd6aa06f8 (diff)
downloadDoxygen-fa9dda01e6c013c7fe9be99b21d8bbf3c95c0482.zip
Doxygen-fa9dda01e6c013c7fe9be99b21d8bbf3c95c0482.tar.gz
Doxygen-fa9dda01e6c013c7fe9be99b21d8bbf3c95c0482.tar.bz2
Show git version information
Show the git version on designated places (currently version, help and Doxyfile difference). The implementation is based on the git_watcher.cmake (https://github.com/andrew-hardin/cmake-git-version-tracking). The information is useful to see which. master, version of doxygen is used for a build on systems where a lot of builds are make (Fossies.org) or very regular builds are made (CGAL) Furthermore the tracking of the VERSION file was not done (when changed the version.cpp was not updated), this is corrected as well.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bf9246..c116bbb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@
# Documents produced by Doxygen are derivative works derived from the
# input used in their production; they are not affected by this license.
-cmake_minimum_required(VERSION 3.1.3)
+cmake_minimum_required(VERSION 3.2)
project(doxygen)
option(build_wizard "Build the GUI frontend for doxygen." OFF)
@@ -110,6 +110,10 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELEASE ${EXECUTABLE_OUTPUT_PATH})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_MINSIZEREL ${EXECUTABLE_OUTPUT_PATH})
set(CMAKE_RUNTIME_OUTPUT_DIRECTORY_RELWITHDEBINFO ${EXECUTABLE_OUTPUT_PATH})
+# setup information for git version handling
+set(PRE_CONFIGURE_GIT_VERSION_FILE "${CMAKE_SOURCE_DIR}/src/gitversion.cpp.in")
+set(POST_CONFIGURE_GIT_VERSION_FILE "${GENERATED_SRC}/gitversion.cpp")
+
# gather lang codes for translation
file(GLOB lang_files RELATIVE "${CMAKE_SOURCE_DIR}/src" "${CMAKE_SOURCE_DIR}/src/translator_??.h")
if (english_only) # user only wants English