summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2019-12-12 12:27:46 (GMT)
committeralbert-github <albert.tests@gmail.com>2019-12-12 12:27:46 (GMT)
commitfe233524d5637944e66d08a3f1bed05e14107956 (patch)
tree7a5e60283edb988bd81f279458c9f1052afb2873 /CMakeLists.txt
parent2ed458302d43a6385c310c685fa4174818f0b67e (diff)
downloadDoxygen-fe233524d5637944e66d08a3f1bed05e14107956.zip
Doxygen-fe233524d5637944e66d08a3f1bed05e14107956.tar.gz
Doxygen-fe233524d5637944e66d08a3f1bed05e14107956.tar.bz2
Adding JAVACC_FLAGS for javacc compilation
During transition to cmake build the, essential for debugging, flag possibility was not added. (Added analogous to LEX_FLAGS and YACC_Flags). Available debug options (according to old Makefile): `-debug_parser` `-debug_token_manager` `-debug_lookahead`
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2644ceb..8ab5aa7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,9 +82,11 @@ set(CMAKE_VISIBILITY_INLINES_HIDDEN 1)
if (CMAKE_GENERATOR MATCHES "Ninja")
set(LEX_FLAGS )
set(YACC_FLAGS )
+ set(JAVACC_FLAGS )
else ()
set(LEX_FLAGS $(LEX_FLAGS))
set(YACC_FLAGS $(YACC_FLAGS))
+ set(JAVACC_FLAGS $(JAVACC_FLAGS))
endif ()
find_program(DOT NAMES dot)