summaryrefslogtreecommitdiffstats
path: root/addon/doxywizard/CMakeLists.txt
diff options
context:
space:
mode:
authorpgajdos <pgajdos@suse.cz>2018-06-19 13:09:36 (GMT)
committerpgajdos <pgajdos@suse.cz>2018-06-19 13:09:36 (GMT)
commita74e24784f4d5b6be5cd2167340a7572d869e220 (patch)
tree9277b8b1089cae3e769af5399eef1f9c2683d74a /addon/doxywizard/CMakeLists.txt
parent4536982bdebc0056d0c5d64a12881f20b5801c06 (diff)
downloadDoxygen-a74e24784f4d5b6be5cd2167340a7572d869e220.zip
Doxygen-a74e24784f4d5b6be5cd2167340a7572d869e220.tar.gz
Doxygen-a74e24784f4d5b6be5cd2167340a7572d869e220.tar.bz2
fix build with qt 5.11, deprecated qt5_use_modules macro was removed, patch by Christophe Giboudeaux
Diffstat (limited to 'addon/doxywizard/CMakeLists.txt')
-rw-r--r--addon/doxywizard/CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
index 0907d23..810c0d0 100644
--- a/addon/doxywizard/CMakeLists.txt
+++ b/addon/doxywizard/CMakeLists.txt
@@ -4,9 +4,6 @@ if (NOT force_qt4)
if (Qt5Core_FOUND)
message(STATUS "Using Qt5")
find_package(Qt5 COMPONENTS Widgets Gui Xml)
- macro(qt_use_modules)
- qt5_use_modules(${ARGN})
- endmacro()
macro(qt_wrap_cpp)
qt5_wrap_cpp(${ARGN})
endmacro()
@@ -23,8 +20,6 @@ if (NOT Qt5Core_FOUND)
message(STATUS "Using Qt4")
endif()
find_package(Qt4 REQUIRED COMPONENTS QtCore QtXml QtGui)
- macro(qt_use_modules)
- endmacro()
macro(qt_wrap_cpp)
qt4_wrap_cpp(${ARGN})
endmacro()
@@ -104,9 +99,11 @@ ${GENERATED_SRC_WIZARD}/configdoc.cpp
${doxywizard_MOC}
${doxywizard_RESOURCES_RCC}
)
-qt_use_modules(doxywizard Core Gui Widgets Xml)
-target_link_libraries(doxywizard
-${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY}
-)
+
+if(Qt5Core_FOUND)
+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
+else()
+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
+endif()
install(TARGETS doxywizard DESTINATION bin)