summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2018-12-05 18:50:14 (GMT)
committeralbert-github <albert.tests@gmail.com>2018-12-05 18:50:14 (GMT)
commit565c21b260ca58c9d6b845ecc64f8c4aaa9a9a96 (patch)
treea0b58da9c2416db29519ce93f4804910e11ecb77 /doc/CMakeLists.txt
parent7bcd67f4affa7c3ce2ba6f652c893488952396a7 (diff)
downloadDoxygen-565c21b260ca58c9d6b845ecc64f8c4aaa9a9a96.zip
Doxygen-565c21b260ca58c9d6b845ecc64f8c4aaa9a9a96.tar.gz
Doxygen-565c21b260ca58c9d6b845ecc64f8c4aaa9a9a96.tar.bz2
Doxygen manual is not XHTML compliant
The doxygen manual is not XHTML compliant. In this, first, fix : - fixes the problems in the doc files (note that docblocks has a small extra problem, pull request for this is #6660) - determine output directory for HTML based on the doxyfile (for images). Note: Remaining problems with examples and old change log files (version 1.5 and earlier)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index e940622..ff5ebc7 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -27,6 +27,17 @@ else()
# doxygen project variables are unknown so look for doxygen in PATH
find_package(Doxygen)
endif()
+#
+# set output directory for some extra HTML files
+#
+file(STRINGS Doxyfile DOXY_HTML_OUTPUT REGEX "HTML_OUTPUT.*")
+string(LENGTH "${DOXY_HTML_OUTPUT}" DOXY_HTML_OUTPUT_LEN)
+if (${DOXY_HTML_OUTPUT_LEN})
+ string(REGEX REPLACE ".*HTML_OUTPUT *= *\([^ ]*\)" "\\1" DOXY_HTML_OUTPUT ${DOXY_HTML_OUTPUT})
+else()
+ set(DOXY_HTML_OUTPUT "html")
+endif()
+set(PROJECT_BINARY_HTML_DIR ${PROJECT_BINARY_DIR}/${DOXY_HTML_OUTPUT}/)
set(DOC_INSTALL_DIR "share/doc/packages/doxygen" CACHE STRING "Relative path where to install the documentation")
set(DOC_FILES
@@ -153,8 +164,8 @@ add_custom_target(doxygen_pdf
WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/latex
)
add_custom_target(docs
- COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/doc/doxygen_logo.gif ${PROJECT_BINARY_DIR}/html/
- COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/doc/doxygen_logo_low.gif ${PROJECT_BINARY_DIR}/html/
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/doc/doxygen_logo.gif ${PROJECT_BINARY_HTML_DIR}
+ COMMAND ${CMAKE_COMMAND} -E copy ${CMAKE_SOURCE_DIR}/doc/doxygen_logo_low.gif ${PROJECT_BINARY_HTML_DIR}
DEPENDS ${PROJECT_BINARY_DIR}/man/doxygen.1
${PROJECT_BINARY_DIR}/man/doxywizard.1
${PROJECT_BINARY_DIR}/man/doxysearch.1