summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2018-11-20 15:54:58 (GMT)
committeralbert-github <albert.tests@gmail.com>2018-11-20 15:54:58 (GMT)
commitca68fbb7cb8937b0a90fcd1b326c00e6e413e70c (patch)
treebf76fc200257e3b39c07e8300754ab24754146d8 /doc/CMakeLists.txt
parent64764a854d8824bb3a9714a159f5ebbd226d3a88 (diff)
downloadDoxygen-ca68fbb7cb8937b0a90fcd1b326c00e6e413e70c.zip
Doxygen-ca68fbb7cb8937b0a90fcd1b326c00e6e413e70c.tar.gz
Doxygen-ca68fbb7cb8937b0a90fcd1b326c00e6e413e70c.tar.bz2
Correct list of not used translator functions
All translator function functions were mentioned as not used. - the directory to find the places where the sources are that use translator functions was pointing to the src directory of the build tree instead the src directory in the source tree (source files are not copied) and thus finding no applicable sources. - furthermore the test whether or not a function was based on the name of a function but in case a name is the short form of an other function and the longer name was not used it was still shown as used.
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 463d3d7..e940622 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -114,7 +114,7 @@ configure_file(${CMAKE_SOURCE_DIR}/doc/doxyindexer.1 ${PROJECT_BINARY_DIR}/
# doc/language.doc (see tag Doxyfile:INPUT)
add_custom_command(
- COMMAND ${PYTHON_EXECUTABLE} translator.py
+ COMMAND ${PYTHON_EXECUTABLE} translator.py ${CMAKE_SOURCE_DIR}
DEPENDS ${PROJECT_BINARY_DIR}/doc/maintainers.txt ${PROJECT_BINARY_DIR}/doc/language.tpl ${PROJECT_BINARY_DIR}/doc/translator.py
OUTPUT language.doc
WORKING_DIRECTORY ${PROJECT_BINARY_DIR}/doc