summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 11:04:48 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 19:05:44 (GMT)
commitfcf5fecb64d5c194430e10cbe52482b14224d645 (patch)
tree4dbc9656f628f5b9096e11eb5c7c34e1865ab1fa /doc/CMakeLists.txt
parent62e87408cb7094eeac130775e62d5b7a6f4a79c9 (diff)
downloadDoxygen-fcf5fecb64d5c194430e10cbe52482b14224d645.zip
Doxygen-fcf5fecb64d5c194430e10cbe52482b14224d645.tar.gz
Doxygen-fcf5fecb64d5c194430e10cbe52482b14224d645.tar.bz2
CMake: use GNUInstallDirs module for man pages directory
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index a7a42e9..b95afd8 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -18,6 +18,7 @@ find_package(PythonInterp REQUIRED)
find_program(EPSTOPDF NAMES epstopdf )
find_program(PDFLATEX NAMES pdflatex )
find_program(MAKEINDEX NAMES makeindex )
+include(GNUInstallDirs)
if (doxygen_BINARY_DIR)
set(DOXYGEN_EXECUTABLE ${doxygen_BINARY_DIR}/bin/doxygen)
@@ -167,7 +168,7 @@ install(FILES
"${PROJECT_BINARY_DIR}/man/doxywizard.1"
"${PROJECT_BINARY_DIR}/man/doxysearch.1"
"${PROJECT_BINARY_DIR}/man/doxyindexer.1"
- DESTINATION share/man/man1
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
)
install(FILES