summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authoralbert-github <albert.tests@gmail.com>2018-12-07 12:30:20 (GMT)
committeralbert-github <albert.tests@gmail.com>2018-12-07 12:30:20 (GMT)
commitdfdf4323434ec466613e9c358da98a4be868986c (patch)
treefb32b0c91ecd71df69285c8f8840633cb4214d4f /examples/CMakeLists.txt
parent7bcd67f4affa7c3ce2ba6f652c893488952396a7 (diff)
downloadDoxygen-dfdf4323434ec466613e9c358da98a4be868986c.zip
Doxygen-dfdf4323434ec466613e9c358da98a4be868986c.tar.gz
Doxygen-dfdf4323434ec466613e9c358da98a4be868986c.tar.bz2
Correcting tag example and uniform calling all examples
- tag example corrected in respect to changed definition (a while ago) regarding the name of the Example example - regenerating tag file (based on current doxygen version) - made building of all examples uniform
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 601ed5a..0f34c6d 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -163,8 +163,9 @@ add_custom_command(
add_custom_command(
COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen tag.cfg
+ COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman_doc.tex
DEPENDS doxygen tag.cpp tag.cfg ${PROJECT_BINARY_DIR}/html/examples/example/html/index.html ${TOP}/examples/strip_example.py
- OUTPUT ${PROJECT_BINARY_DIR}/html/examples/tag/html/index.html
+ OUTPUT ${PROJECT_BINARY_DIR}/html/examples/tag/html/index.html ${PROJECT_BINARY_DIR}/html/examples/tag/latex/refman_doc.tex
)
add_custom_command(
@@ -183,8 +184,9 @@ add_custom_command(
add_custom_command(
COMMAND ${EXECUTABLE_OUTPUT_PATH}/doxygen templ.cfg
+ COMMAND ${PYTHON_EXECUTABLE} ${TOP}/examples/strip_example.py < ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman.tex > ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman_doc.tex
DEPENDS doxygen templ.cpp templ.cfg ${TOP}/examples/strip_example.py
- OUTPUT ${PROJECT_BINARY_DIR}/html/examples/template/html/index.html
+ OUTPUT ${PROJECT_BINARY_DIR}/html/examples/template/html/index.html ${PROJECT_BINARY_DIR}/html/examples/template/latex/refman_doc.tex
)
add_custom_command(