summaryrefslogtreecommitdiffstats
path: root/testing/CMakeLists.txt
diff options
context:
space:
mode:
authorRolf Eike Beer <eb@emlix.com>2017-10-20 10:45:45 (GMT)
committerRolf Eike Beer <kde@opensource.sf-tec.de>2017-10-20 19:05:44 (GMT)
commitb54b843accb97105ae4afaf24136e33bfd1ea9d4 (patch)
tree9230e366942fd20edd530f2e650f38453519a1a0 /testing/CMakeLists.txt
parentca7e60edd370949cfb2adb83ca0b532bb3fdc441 (diff)
downloadDoxygen-b54b843accb97105ae4afaf24136e33bfd1ea9d4.zip
Doxygen-b54b843accb97105ae4afaf24136e33bfd1ea9d4.tar.gz
Doxygen-b54b843accb97105ae4afaf24136e33bfd1ea9d4.tar.bz2
CMake: use add_test to create a test
This checks the calling from "make tests" to "make test", but lets CMake handle all the rest.
Diffstat (limited to 'testing/CMakeLists.txt')
-rw-r--r--testing/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/testing/CMakeLists.txt b/testing/CMakeLists.txt
index d9f35ff..84162ea 100644
--- a/testing/CMakeLists.txt
+++ b/testing/CMakeLists.txt
@@ -1,6 +1,4 @@
-add_custom_target(tests
- COMMENT "Running doxygen tests..."
- COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen ${PROJECT_BINARY_DIR}/bin/doxygen --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
- DEPENDS doxygen
+add_test(NAME suite
+ COMMAND ${PYTHON_EXECUTABLE} ${CMAKE_SOURCE_DIR}/testing/runtests.py --all --doxygen $<TARGET_FILE:doxygen> --inputdir ${CMAKE_SOURCE_DIR}/testing --outputdir ${PROJECT_BINARY_DIR}/testing
)