summaryrefslogtreecommitdiffstats
path: root/vhdlparser/CMakeLists.txt
diff options
context:
space:
mode:
authorCosta Shulyupin <costa@MakeLinux.net>2020-06-27 21:15:45 (GMT)
committerCosta Shulyupin <CostaS@AttentiGroup.com>2020-06-28 10:07:30 (GMT)
commit825030e80bdf7273887eea854308d0e51855d3e7 (patch)
tree369709c2d1c20386bb6ecab4a297df9e708bbbaf /vhdlparser/CMakeLists.txt
parentd5916c06fba9667911a19cf658e7c5ab54daf72c (diff)
downloadDoxygen-825030e80bdf7273887eea854308d0e51855d3e7.zip
Doxygen-825030e80bdf7273887eea854308d0e51855d3e7.tar.gz
Doxygen-825030e80bdf7273887eea854308d0e51855d3e7.tar.bz2
remove vhdlparser/Makefile
because it is generated from vhdlparser/CMakeLists.txt
Diffstat (limited to 'vhdlparser/CMakeLists.txt')
-rw-r--r--vhdlparser/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/vhdlparser/CMakeLists.txt b/vhdlparser/CMakeLists.txt
index 343f126..53983f5 100644
--- a/vhdlparser/CMakeLists.txt
+++ b/vhdlparser/CMakeLists.txt
@@ -1,3 +1,18 @@
+#
+# Generate parser (default target)
+#
+# when generating the parser with debug options it will look like:
+# make JAVACC_FLAGS=-debug_parser
+# or
+# make JAVACC_FLAGS="-debug_parser -debug_lookahead"
+#
+# Available debug options:
+# -debug_parser
+# -debug_token_manager
+# -debug_lookahead
+#
+# For other javacc settings / options consult the documentation of javacc.
+
find_package(Javacc)
if (JAVACC_FOUND)
if (JAVACC_VERSION VERSION_LESS 7.0.5)