summaryrefslogtreecommitdiffstats
path: root/addon/doxmlparser/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'addon/doxmlparser/setup.py')
-rw-r--r--addon/doxmlparser/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/addon/doxmlparser/setup.py b/addon/doxmlparser/setup.py
new file mode 100644
index 0000000..02a0496
--- /dev/null
+++ b/addon/doxmlparser/setup.py
@@ -0,0 +1,19 @@
+from setuptools import setup, find_packages
+
+with open('README.md') as f:
+ readme = f.read()
+
+with open('LICENSE') as f:
+ license = f.read()
+
+setup(
+ name='doxmlparser',
+ version='0.1',
+ description='Python API to access doxygen generated XML output',
+ long_description=readme,
+ author='Dimitri van Heesch',
+ author_email='doxygen@gmail.com',
+ url='https://github.com/doxygen/doxygen/addon/doxmlparser',
+ license=license,
+ packages=find_packages(exclude=('tests', 'docs'))
+)