summaryrefslogtreecommitdiffstats
path: root/addon/doxysearch/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'addon/doxysearch/CMakeLists.txt')
-rw-r--r--addon/doxysearch/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/addon/doxysearch/CMakeLists.txt b/addon/doxysearch/CMakeLists.txt
index e3511aa..33e01c1 100644
--- a/addon/doxysearch/CMakeLists.txt
+++ b/addon/doxysearch/CMakeLists.txt
@@ -3,6 +3,10 @@ if (build_search)
find_package(Xapian REQUIRED)
find_package(ZLIB REQUIRED)
+if (WIN32)
+ set(WIN_EXTRA_LIBS "uuid.lib rpcrt4.lib ws2_32.lib")
+endif()
+
include_directories(
${CMAKE_SOURCE_DIR}/qtools
${XAPIAN_INCLUDE_DIR}
@@ -14,6 +18,7 @@ add_executable(doxyindexer
target_link_libraries(doxyindexer
${XAPIAN_LIBRARIES}
${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
qtools
)
@@ -23,6 +28,7 @@ add_executable(doxysearch.cgi
target_link_libraries(doxysearch.cgi
${XAPIAN_LIBRARIES}
${ZLIB_LIBRARIES}
+ ${WIN_EXTRA_LIBS}
)
install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)