summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHelenerineium <photosynthesis2728@gmail.com>2019-11-23 09:47:44 (GMT)
committerHelenerineium <photosynthesis2728@gmail.com>2019-11-23 09:47:44 (GMT)
commit288f04eb171f18818950ffb235ded7c11e3cc92b (patch)
tree15f3304bc3aaf3ed58022ddc14dc97f32cd71f00 /CMakeLists.txt
parented154b90522eaa47f255f416e882de9f9771aadf (diff)
downloadNinja-288f04eb171f18818950ffb235ded7c11e3cc92b.zip
Ninja-288f04eb171f18818950ffb235ded7c11e3cc92b.tar.gz
Ninja-288f04eb171f18818950ffb235ded7c11e3cc92b.tar.bz2
Fix warnings on mingw build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2390732..582e0ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ endif()
#Fixes GetActiveProcessorCount on MinGW
if(MINGW)
-target_compile_definitions(libninja PRIVATE _WIN32_WINNT=0x0601)
+target_compile_definitions(libninja PRIVATE _WIN32_WINNT=0x0601 __USE_MINGW_ANSI_STDIO=1)
endif()
# Main executable is library plus main() function.