summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Niklas Hasse <jhasse@bixense.com>2021-02-23 09:00:23 (GMT)
committerGitHub <noreply@github.com>2021-02-23 09:00:23 (GMT)
commitec8de9c247dde02c447cff23cb826a7524110e79 (patch)
treee733ce0faa3ec06bcebcaaca4814e77aa5719e3f /CMakeLists.txt
parentc83f00c8a641901339a9d04ff00e2a1212b49ab9 (diff)
parent00459e2b44fe1ee1a508f562bdf05acbea99c181 (diff)
downloadNinja-ec8de9c247dde02c447cff23cb826a7524110e79.zip
Ninja-ec8de9c247dde02c447cff23cb826a7524110e79.tar.gz
Ninja-ec8de9c247dde02c447cff23cb826a7524110e79.tar.bz2
Merge pull request #1915 from jhasse/windows-utf8
Use UTF-8 on Windows 10 Version 1903, fix #1195
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0fa1bd2..fe2fae7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -138,6 +138,10 @@ endif()
add_executable(ninja src/ninja.cc)
target_link_libraries(ninja PRIVATE libninja libninja-re2c)
+if(WIN32)
+ target_sources(ninja PRIVATE windows/ninja.manifest)
+endif()
+
# Adds browse mode into the ninja binary if it's supported by the host platform.
if(platform_supports_ninja_browse)
# Inlines src/browse.py into the browse_py.h header, so that it can be included