diff options
author | Steven Knight <knight@baldmt.com> | 2003-08-30 16:08:56 (GMT) |
---|---|---|
committer | Steven Knight <knight@baldmt.com> | 2003-08-30 16:08:56 (GMT) |
commit | 0d3be1bac1e8d3c3edb574ef918cc44c24286f0b (patch) | |
tree | 584aa6ab615466c224a765f36a55b076983a02c2 /SConstruct | |
parent | bfc84b0f38ad74bd181df2b0938f0bd94e774cd4 (diff) | |
download | SCons-0d3be1bac1e8d3c3edb574ef918cc44c24286f0b.zip SCons-0d3be1bac1e8d3c3edb574ef918cc44c24286f0b.tar.gz SCons-0d3be1bac1e8d3c3edb574ef918cc44c24286f0b.tar.bz2 |
Fix unpacking the .zip packages even if there are no source changes.
Diffstat (limited to 'SConstruct')
-rw-r--r-- | SConstruct | 10 |
1 files changed, 8 insertions, 2 deletions
@@ -642,7 +642,10 @@ for p in [ scons ]: os.path.join(u, pv, x), src_files) - env.Command(unpack_zip_files, zip, unzipit) + env.Command(unpack_zip_files, zip, [ + "rm -rf %s" % os.path.join(unpack_zip_dir, pkg_version), + unzipit + ]) # # Run setup.py in the unpacked subdirectory to "install" everything @@ -1013,7 +1016,10 @@ if change: os.path.join(u, psv, x), sfiles) - env.Command(unpack_zip_files, src_zip, unzipit) + env.Command(unpack_zip_files, src_zip, [ + "rm -rf %s" % os.path.join(unpack_zip_dir, psv), + unzipit + ]) # # Run setup.py in the unpacked subdirectory to "install" everything |