diff options
author | Steven Knight <knight@baldmt.com> | 2002-02-05 20:08:29 (GMT) |
---|---|---|
committer | Steven Knight <knight@baldmt.com> | 2002-02-05 20:08:29 (GMT) |
commit | f6c20c8f66928d7d9845717cca12770dbfc86a59 (patch) | |
tree | 279913aaaa33e5ec28f3699a4a3c894336f56e87 /SConstruct | |
parent | ac9aa00b71169ab6d275ee6990248e1778bcf456 (diff) | |
download | SCons-f6c20c8f66928d7d9845717cca12770dbfc86a59.zip SCons-f6c20c8f66928d7d9845717cca12770dbfc86a59.tar.gz SCons-f6c20c8f66928d7d9845717cca12770dbfc86a59.tar.bz2 |
Make scons return a failure code when a Builder fails (Anthony Roach)
Diffstat (limited to 'SConstruct')
-rw-r--r-- | SConstruct | 14 |
1 files changed, 7 insertions, 7 deletions
@@ -47,12 +47,13 @@ Default('.') def whereis(file): for dir in string.split(os.environ['PATH'], os.pathsep): f = os.path.join(dir, file) - try: - st = os.stat(f) - except: - continue - if stat.S_IMODE(st[stat.ST_MODE]) & 0111: - return f + if os.path.isfile(f): + try: + st = os.stat(f) + except: + continue + if stat.S_IMODE(st[stat.ST_MODE]) & 0111: + return f return None # @@ -356,7 +357,6 @@ for p in [ scons ]: # README.txt, or setup.py. Make a copy of the list for the # destination files. # - global src_files src_files = map(lambda x: x[:-1], open(os.path.join(src, 'MANIFEST.in')).readlines()) dst_files = map(lambda x: os.path.join(install, x), src_files) |