summaryrefslogtreecommitdiffstats
path: root/src/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/setup.py b/src/setup.py
index 9378770..0dbb012 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -20,13 +20,13 @@
# OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
# WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
#
+from __future__ import generators ### KEEP FOR COMPATIBILITY FIXERS
__revision__ = "__FILE__ __REVISION__ __DATE__ __DEVELOPER__"
import os
import os.path
import stat
-import string
import sys
Version = "__VERSION__"
@@ -198,7 +198,7 @@ def get_scons_prefix(libdir, is_win32):
if head == os.sep:
break
head, tail = os.path.split(head)
- if string.lower(tail)[:6] == "python":
+ if tail.lower()[:6] == "python":
# Found the Python library directory...
if is_win32:
# ...on Win32 systems, "scons" goes in the directory:
@@ -297,8 +297,8 @@ class install_scripts(_install_scripts):
create_version_script = self.do_nothing
inputs = self.get_inputs()
- bat_scripts = filter(lambda x: x[-4:] == '.bat', inputs)
- non_bat_scripts = filter(lambda x: x[-4:] != '.bat', inputs)
+ bat_scripts = [x for x in inputs if x[-4:] == '.bat']
+ non_bat_scripts = [x for x in inputs if x[-4:] != '.bat']
self.outfiles = []
self.mkpath(self.install_dir)
@@ -415,10 +415,10 @@ arguments = {
'build_scripts' : build_scripts}
}
-apply(distutils.core.setup, (), arguments)
+distutils.core.setup(**arguments)
if Installed:
- print string.join(Installed, '\n')
+ print '\n'.join(Installed)
# Local Variables:
# tab-width:4