summaryrefslogtreecommitdiffstats
path: root/libxml2/doc/devhelp/Makefile.am
diff options
context:
space:
mode:
authorWilliam Joye <wjoye@cfa.harvard.edu>2016-11-17 21:10:17 (GMT)
committerWilliam Joye <wjoye@cfa.harvard.edu>2016-11-17 21:10:17 (GMT)
commit8096d34300076a1aa9cb517de49fb920a051939f (patch)
tree5f2b1b7c41f89fedc31af973d6a747ca674cfd24 /libxml2/doc/devhelp/Makefile.am
parentfc7f7edd0b8011cb71573b15462ef83068d9e54b (diff)
parent574585fa78070b0cc6b5ad22543e21a3502a122b (diff)
downloadblt-8096d34300076a1aa9cb517de49fb920a051939f.zip
blt-8096d34300076a1aa9cb517de49fb920a051939f.tar.gz
blt-8096d34300076a1aa9cb517de49fb920a051939f.tar.bz2
Merge commit '574585fa78070b0cc6b5ad22543e21a3502a122b' as 'libxml2'
Diffstat (limited to 'libxml2/doc/devhelp/Makefile.am')
-rw-r--r--libxml2/doc/devhelp/Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/libxml2/doc/devhelp/Makefile.am b/libxml2/doc/devhelp/Makefile.am
new file mode 100644
index 0000000..dad7975
--- /dev/null
+++ b/libxml2/doc/devhelp/Makefile.am
@@ -0,0 +1,79 @@
+devhelpdir = $(datadir)/gtk-doc/html/libxml2
+
+dist_devhelp_DATA = \
+ libxml2.devhelp \
+ $(HTML_FILES) \
+ $(EXTRA_FORMAT)
+
+HTML_FILES = \
+ general.html \
+ index.html \
+ $(HTML_MODULES)
+
+HTML_MODULES= \
+ libxml2-c14n.html \
+ libxml2-catalog.html \
+ libxml2-chvalid.html \
+ libxml2-debugXML.html \
+ libxml2-dict.html \
+ libxml2-DOCBparser.html \
+ libxml2-encoding.html \
+ libxml2-entities.html \
+ libxml2-globals.html \
+ libxml2-hash.html \
+ libxml2-HTMLparser.html \
+ libxml2-HTMLtree.html \
+ libxml2-list.html \
+ libxml2-nanoftp.html \
+ libxml2-nanohttp.html \
+ libxml2-parser.html \
+ libxml2-parserInternals.html \
+ libxml2-pattern.html \
+ libxml2-relaxng.html \
+ libxml2-SAX2.html \
+ libxml2-SAX.html \
+ libxml2-schemasInternals.html \
+ libxml2-schematron.html \
+ libxml2-threads.html \
+ libxml2-tree.html \
+ libxml2-uri.html \
+ libxml2-valid.html \
+ libxml2-xinclude.html \
+ libxml2-xlink.html \
+ libxml2-xmlautomata.html \
+ libxml2-xmlerror.html \
+ libxml2-xmlexports.html \
+ libxml2-xmlIO.html \
+ libxml2-xmlmemory.html \
+ libxml2-xmlmodule.html \
+ libxml2-xmlreader.html \
+ libxml2-xmlregexp.html \
+ libxml2-xmlsave.html \
+ libxml2-xmlschemas.html \
+ libxml2-xmlschemastypes.html \
+ libxml2-xmlstring.html \
+ libxml2-xmlunicode.html \
+ libxml2-xmlversion.html \
+ libxml2-xmlwriter.html \
+ libxml2-xpath.html \
+ libxml2-xpathInternals.html \
+ libxml2-xpointer.html
+
+EXTRA_FORMAT= \
+ home.png \
+ left.png \
+ right.png \
+ up.png \
+ style.css
+
+EXTRA_DIST = devhelp.xsl html.xsl
+
+if REBUILD_DOCS
+rebuild: libxml2.devhelp $(HTML_FILES)
+.PHONY: rebuild
+
+libxml2.devhelp $(HTML_FILES): devhelp.xsl html.xsl $(top_srcdir)/doc/libxml2-api.xml
+ -@(if [ -x $(XSLTPROC) ] ; then \
+ echo Rebuilding devhelp files ; \
+ $(XSLTPROC) --nonet -o $(srcdir)/libxml2.devhelp $(srcdir)/devhelp.xsl $(top_srcdir)/doc/libxml2-api.xml ; fi );
+endif