summaryrefslogtreecommitdiffstats
path: root/tcliis/configure.ac
diff options
context:
space:
mode:
authorWilliam Joye <wjoye@cfa.harvard.edu>2018-12-27 19:40:41 (GMT)
committerWilliam Joye <wjoye@cfa.harvard.edu>2018-12-27 19:40:41 (GMT)
commit0903c8ce50445b763bdd09ef1437b4b06992f2b0 (patch)
treebf29eb627e745c5c703ed942686bbcd25208a1c3 /tcliis/configure.ac
parent6de585e45464bc7859b30dacf656af9ec29ce1a2 (diff)
downloadblt-0903c8ce50445b763bdd09ef1437b4b06992f2b0.zip
blt-0903c8ce50445b763bdd09ef1437b4b06992f2b0.tar.gz
blt-0903c8ce50445b763bdd09ef1437b4b06992f2b0.tar.bz2
update TEA 3.13
Diffstat (limited to 'tcliis/configure.ac')
-rw-r--r--tcliis/configure.ac38
1 files changed, 18 insertions, 20 deletions
diff --git a/tcliis/configure.ac b/tcliis/configure.ac
index ea40cc7..e306ad0 100644
--- a/tcliis/configure.ac
+++ b/tcliis/configure.ac
@@ -19,7 +19,7 @@ dnl to configure the system for the local environment.
# so that we create the export library with the dll.
#-----------------------------------------------------------------------
-AC_INIT([tcliis], [1.0])
+AC_INIT([sample], [0.5])
#--------------------------------------------------------------------
# Call TEA_INIT as the first TEA_ macro to set up initial vars.
@@ -27,7 +27,7 @@ AC_INIT([tcliis], [1.0])
# as well as PKG_LIB_FILE and PKG_STUB_LIB_FILE.
#--------------------------------------------------------------------
-TEA_INIT([3.10])
+TEA_INIT()
AC_CONFIG_AUX_DIR(tclconfig)
@@ -71,24 +71,14 @@ TEA_SETUP_COMPILER
# and PKG_TCL_SOURCES.
#-----------------------------------------------------------------------
-TEA_ADD_SOURCES([
- iistcl.C
- xim.C
- iis.c
- util.c
- ])
+TEA_ADD_SOURCES([sample.c tclsample.c])
TEA_ADD_HEADERS([])
TEA_ADD_INCLUDES([])
-TEA_ADD_LIBS([-lstdc++])
+TEA_ADD_LIBS([])
TEA_ADD_CFLAGS([])
TEA_ADD_STUB_SOURCES([])
TEA_ADD_TCL_SOURCES([])
-# Needed to compile open_unix
-if test "${TEA_PLATFORM}" != "windows" ; then
-AC_CHECK_HEADERS(sys/un.h)
-fi
-
#--------------------------------------------------------------------
# __CHANGE__
#
@@ -178,16 +168,24 @@ TEA_PROG_TCLSH
#TEA_PROG_WISH
#--------------------------------------------------------------------
-# These are for tcliisConfig.sh
+# Setup a *Config.sh.in configuration file.
#--------------------------------------------------------------------
-TEA_EXPORT_CONFIG([tcliis])
+#TEA_EXPORT_CONFIG([sample])
+#AC_SUBST(SAMPLE_VAR)
#--------------------------------------------------------------------
-# Finally, substitute all of the various values into the Makefile.
-# You may alternatively have a special pkgIndex.tcl.in or other files
-# which require substituting th AC variables in. Include these here.
+# Specify files to substitute AC variables in. You may alternatively
+# have a special pkgIndex.tcl.in or other files which require
+# substituting the AC variables in. Include these here.
#--------------------------------------------------------------------
-AC_OUTPUT([Makefile pkgIndex.tcl tcliisConfig.sh])
+AC_CONFIG_FILES([Makefile pkgIndex.tcl])
+#AC_CONFIG_FILES([sampleConfig.sh])
+
+#--------------------------------------------------------------------
+# Finally, substitute all of the various values into the files
+# specified with AC_CONFIG_FILES.
+#--------------------------------------------------------------------
+AC_OUTPUT()