summaryrefslogtreecommitdiffstats
path: root/tkblt/configure.ac
diff options
context:
space:
mode:
authorWilliam Joye <wjoye@cfa.harvard.edu>2019-03-22 18:47:42 (GMT)
committerWilliam Joye <wjoye@cfa.harvard.edu>2019-03-22 18:47:42 (GMT)
commitb30a3539186f8949407967c4e21f6f36c7acc788 (patch)
treea64b1c8e30c82ca806ed8e3ca17581b2f769996e /tkblt/configure.ac
parent5536024a26c61550eca4aec9737cd5eba8646ff9 (diff)
parenta488074b144e3eb3b21b1e8439fb36ce064ad6d2 (diff)
downloadblt-b30a3539186f8949407967c4e21f6f36c7acc788.zip
blt-b30a3539186f8949407967c4e21f6f36c7acc788.tar.gz
blt-b30a3539186f8949407967c4e21f6f36c7acc788.tar.bz2
Merge commit 'a488074b144e3eb3b21b1e8439fb36ce064ad6d2' as 'tkblt'
Diffstat (limited to 'tkblt/configure.ac')
-rw-r--r--tkblt/configure.ac246
1 files changed, 246 insertions, 0 deletions
diff --git a/tkblt/configure.ac b/tkblt/configure.ac
new file mode 100644
index 0000000..5bbfab0
--- /dev/null
+++ b/tkblt/configure.ac
@@ -0,0 +1,246 @@
+#!/bin/bash -norc
+dnl This file is an input file used by the GNU "autoconf" program to
+dnl generate the file "configure", which is run during Tcl installation
+dnl to configure the system for the local environment.
+
+#-----------------------------------------------------------------------
+# Sample configure.ac for Tcl Extensions. The only places you should
+# need to modify this file are marked by the string __CHANGE__
+#-----------------------------------------------------------------------
+
+#-----------------------------------------------------------------------
+# __CHANGE__
+# Set your package name and version numbers here.
+#
+# This initializes the environment with PACKAGE_NAME and PACKAGE_VERSION
+# set as provided. These will also be added as -D defs in your Makefile
+# so you can encode the package version directly into the source files.
+# This will also define a special symbol for Windows (BUILD_<PACKAGE_NAME>
+# so that we create the export library with the dll.
+#-----------------------------------------------------------------------
+
+AC_INIT([tkblt], [3.2])
+
+#--------------------------------------------------------------------
+# Call TEA_INIT as the first TEA_ macro to set up initial vars.
+# This will define a ${TEA_PLATFORM} variable == "unix" or "windows"
+# as well as PKG_LIB_FILE and PKG_STUB_LIB_FILE.
+#--------------------------------------------------------------------
+
+TEA_INIT()
+
+AC_CONFIG_AUX_DIR(tclconfig)
+
+#--------------------------------------------------------------------
+# Load the tclConfig.sh file
+#--------------------------------------------------------------------
+
+TEA_PATH_TCLCONFIG
+TEA_LOAD_TCLCONFIG
+
+#--------------------------------------------------------------------
+# Load the tkConfig.sh file if necessary (Tk extension)
+#--------------------------------------------------------------------
+
+TEA_PATH_TKCONFIG
+TEA_LOAD_TKCONFIG
+
+#-----------------------------------------------------------------------
+# Handle the --prefix=... option by defaulting to what Tcl gave.
+# Must be called after TEA_LOAD_TCLCONFIG and before TEA_SETUP_COMPILER.
+#-----------------------------------------------------------------------
+
+TEA_PREFIX
+
+#-----------------------------------------------------------------------
+# Standard compiler checks.
+# This sets up CC by using the CC env var, or looks for gcc otherwise.
+# This also calls AC_PROG_CC and a few others to create the basic setup
+# necessary to compile executables.
+#-----------------------------------------------------------------------
+
+TEA_SETUP_COMPILER
+
+#-----------------------------------------------------------------------
+# __CHANGE__
+# Specify the C source files to compile in TEA_ADD_SOURCES,
+# public headers that need to be installed in TEA_ADD_HEADERS,
+# stub library C source files to compile in TEA_ADD_STUB_SOURCES,
+# and runtime Tcl library files in TEA_ADD_TCL_SOURCES.
+# This defines PKG(_STUB)_SOURCES, PKG(_STUB)_OBJECTS, PKG_HEADERS
+# and PKG_TCL_SOURCES.
+#-----------------------------------------------------------------------
+
+TEA_ADD_SOURCES([
+tkbltChain.C
+tkbltConfig.C
+tkbltGrAxis.C
+tkbltGrAxisOp.C
+tkbltGrAxisOption.C
+tkbltGrBind.C
+tkbltGrElemOp.C
+tkbltGrElemOption.C
+tkbltGrElem.C
+tkbltGrElemBar.C
+tkbltGrElemLine.C
+tkbltGrElemLineSpline.C
+tkbltGrHairs.C
+tkbltGrHairsOp.C
+tkbltGrLegd.C
+tkbltGrLegdOp.C
+tkbltGrMarkerOp.C
+tkbltGrMarkerOption.C
+tkbltGrMarker.C
+tkbltGrMarkerLine.C
+tkbltGrMarkerPolygon.C
+tkbltGrMarkerText.C
+tkbltGrMisc.C
+tkbltGrPenOp.C
+tkbltGrPenOption.C
+tkbltGrPen.C
+tkbltGrPenBar.C
+tkbltGrPenLine.C
+tkbltGrPostscript.C
+tkbltGrPostscriptOp.C
+tkbltGrPSOutput.C
+tkbltGrText.C
+tkbltGrXAxisOp.C
+tkbltGraph.C
+tkbltGraphBar.C
+tkbltGraphLine.C
+tkbltGraphOp.C
+tkbltGraphSup.C
+tkbltInt.C
+tkbltNsUtil.C
+tkbltParse.C
+tkbltOp.C
+tkbltStubInit.c
+tkbltStubLib.C
+tkbltSwitch.C
+tkbltVecCmd.C
+tkbltVecOp.C
+tkbltVecMath.C
+tkbltVector.C
+])
+TEA_ADD_HEADERS([
+generic/tkbltVector.h
+generic/tkbltDecls.h
+])
+TEA_ADD_INCLUDES([])
+TEA_ADD_LIBS([-lstdc++])
+if test "${TEA_PLATFORM}" = "windows" -a "$GCC" != "yes"; then
+TEA_ADD_CFLAGS([-TP -EHsc -D_CRT_SECURE_NO_WARNINGS -D_USE_MATH_DEFINES])
+fi
+TEA_ADD_STUB_SOURCES([tkbltStubLib.C])
+TEA_ADD_TCL_SOURCES([library/graph.tcl])
+
+#--------------------------------------------------------------------
+# __CHANGE__
+#
+# You can add more files to clean if your extension creates any extra
+# files by extending CLEANFILES.
+# Add pkgIndex.tcl if it is generated in the Makefile instead of ./configure
+# and change Makefile.in to move it from CONFIG_CLEAN_FILES to BINARIES var.
+#
+# A few miscellaneous platform-specific items:
+# TEA_ADD_* any platform specific compiler/build info here.
+#--------------------------------------------------------------------
+
+#CLEANFILES="$CLEANFILES pkgIndex.tcl"
+if test "${TEA_PLATFORM}" = "windows" ; then
+ # Ensure no empty if clauses
+ :
+ #TEA_ADD_SOURCES([win/winFile.c])
+ #TEA_ADD_INCLUDES([-I\"$(${CYGPATH} ${srcdir}/win)\"])
+else
+ # Ensure no empty else clauses
+ :
+ #TEA_ADD_SOURCES([unix/unixFile.c])
+ #TEA_ADD_LIBS([-lsuperfly])
+fi
+
+#--------------------------------------------------------------------
+# __CHANGE__
+# Choose which headers you need. Extension authors should try very
+# hard to only rely on the Tcl public header files. Internal headers
+# contain private data structures and are subject to change without
+# notice.
+# This MUST be called after TEA_LOAD_TCLCONFIG / TEA_LOAD_TKCONFIG
+#--------------------------------------------------------------------
+
+TEA_PUBLIC_TCL_HEADERS
+TEA_PRIVATE_TCL_HEADERS
+
+TEA_PUBLIC_TK_HEADERS
+TEA_PRIVATE_TK_HEADERS
+TEA_PATH_X
+
+#--------------------------------------------------------------------
+# Check whether --enable-threads or --disable-threads was given.
+# This auto-enables if Tcl was compiled threaded.
+#--------------------------------------------------------------------
+
+TEA_ENABLE_THREADS
+
+#--------------------------------------------------------------------
+# The statement below defines a collection of symbols related to
+# building as a shared library instead of a static library.
+#--------------------------------------------------------------------
+
+TEA_ENABLE_SHARED
+
+#--------------------------------------------------------------------
+# This macro figures out what flags to use with the compiler/linker
+# when building shared/static debug/optimized objects. This information
+# can be taken from the tclConfig.sh file, but this figures it all out.
+#--------------------------------------------------------------------
+
+TEA_CONFIG_CFLAGS
+
+#--------------------------------------------------------------------
+# Set the default compiler switches based on the --enable-symbols option.
+#--------------------------------------------------------------------
+
+TEA_ENABLE_SYMBOLS
+
+#--------------------------------------------------------------------
+# This macro generates a line to use when building a library. It
+# depends on values set by the TEA_ENABLE_SHARED, TEA_ENABLE_SYMBOLS,
+# and TEA_LOAD_TCLCONFIG macros above.
+#--------------------------------------------------------------------
+
+TEA_MAKE_LIB
+
+#--------------------------------------------------------------------
+# Determine the name of the tclsh and/or wish executables in the
+# Tcl and Tk build directories or the location they were installed
+# into. These paths are used to support running test cases only,
+# the Makefile should not be making use of these paths to generate
+# a pkgIndex.tcl file or anything else at extension build time.
+#--------------------------------------------------------------------
+
+TEA_PROG_TCLSH
+TEA_PROG_WISH
+
+#--------------------------------------------------------------------
+# Setup a *Config.sh.in configuration file.
+#--------------------------------------------------------------------
+
+TEA_EXPORT_CONFIG([tkblt])
+#AC_SUBST(SAMPLE_VAR)
+
+#--------------------------------------------------------------------
+# Specify files to substitute AC variables in. You may alternatively
+# have a special pkgIndex.tcl.in or other files which require
+# substituting the AC variables in. Include these here.
+#--------------------------------------------------------------------
+
+AC_CONFIG_FILES([Makefile pkgIndex.tcl])
+AC_CONFIG_FILES([tkbltConfig.sh])
+
+#--------------------------------------------------------------------
+# Finally, substitute all of the various values into the files
+# specified with AC_CONFIG_FILES.
+#--------------------------------------------------------------------
+
+AC_OUTPUT()