summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5aeae27..4d8f5e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,9 +59,12 @@ TEA_PREFIX
# necessary to compile executables.
#-----------------------------------------------------------------------
-AC_PROG_CXX
TEA_SETUP_COMPILER
+if test "${TEA_PLATFORM}" != "windows" ; then
+ AC_PROG_CXX
+fi
+
#-----------------------------------------------------------------------
# __CHANGE__
# Specify the C source files to compile in TEA_ADD_SOURCES,
@@ -198,6 +201,11 @@ TEA_ENABLE_SHARED
TEA_CONFIG_CFLAGS
+if test "${TEA_PLATFORM}" = "windows" ; then
+ CXX="$CC"
+ CXXFLAGS="$CFLAGS"
+fi
+
#--------------------------------------------------------------------
# Set the default compiler switches based on the --enable-symbols option.
#--------------------------------------------------------------------