summaryrefslogtreecommitdiffstats
path: root/ds9/unix/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'ds9/unix/configure.ac')
-rw-r--r--ds9/unix/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/ds9/unix/configure.ac b/ds9/unix/configure.ac
index 7738d4e..13b3243 100644
--- a/ds9/unix/configure.ac
+++ b/ds9/unix/configure.ac
@@ -76,6 +76,9 @@ TEA_LOAD_CONFIG(tclxml)
TEA_PATH_CONFIG(tclzvfs)
TEA_LOAD_CONFIG(tclzvfs)
+TEA_PATH_CONFIG(tls)
+TEA_LOAD_CONFIG(tls)
+
TEA_PATH_CONFIG(tkblt)
TEA_LOAD_CONFIG(tkblt)
@@ -147,10 +150,13 @@ TEA_CONFIG_SYSTEM
case $system in
Darwin*)
AC_DEFINE([ZIPFILE])
+ SSLLIBS="/opt/local/lib/libssl.a /opt/local/lib/libcrypto.a"
;;
*)
+ SSLLIBS="-lssl -lcrypto"
;;
esac
+AC_SUBST(SSLLIBS)
AC_SUBST(system)
AC_CHECK_LIB([xml2],[xmlInitParser])