summaryrefslogtreecommitdiffstats
path: root/ds9/win/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'ds9/win/configure.ac')
-rw-r--r--ds9/win/configure.ac29
1 files changed, 22 insertions, 7 deletions
diff --git a/ds9/win/configure.ac b/ds9/win/configure.ac
index b44fbc3..c5be2df 100644
--- a/ds9/win/configure.ac
+++ b/ds9/win/configure.ac
@@ -19,7 +19,7 @@ dnl to configure the system for the local environment.
# so that we create the export library with the dll.
#-----------------------------------------------------------------------
-AC_INIT([ds9], [8.0])
+AC_INIT([ds9], [8.1])
#--------------------------------------------------------------------
# Call TEA_INIT as the first TEA_ macro to set up initial vars.
@@ -27,7 +27,7 @@ AC_INIT([ds9], [8.0])
# as well as PKG_LIB_FILE and PKG_STUB_LIB_FILE.
#--------------------------------------------------------------------
-TEA_INIT([3.10])
+TEA_INIT()
AC_CONFIG_AUX_DIR(../tclconfig)
@@ -186,7 +186,7 @@ TEA_PUBLIC_TK_HEADERS
# This auto-enables if Tcl was compiled threaded.
#--------------------------------------------------------------------
-#TEA_ENABLE_THREADS
+TEA_ENABLE_THREADS
#--------------------------------------------------------------------
# The statement below defines a collection of symbols related to
@@ -229,9 +229,24 @@ TEA_PROG_TCLSH
#TEA_PROG_WISH
#--------------------------------------------------------------------
-# Finally, substitute all of the various values into the Makefile.
-# You may alternatively have a special pkgIndex.tcl.in or other files
-# which require substituting th AC variables in. Include these here.
+# Setup a *Config.sh.in configuration file.
#--------------------------------------------------------------------
-AC_OUTPUT([Makefile])
+#TEA_EXPORT_CONFIG([sample])
+#AC_SUBST(SAMPLE_VAR)
+
+#--------------------------------------------------------------------
+# Specify files to substitute AC variables in. You may alternatively
+# have a special pkgIndex.tcl.in or other files which require
+# substituting the AC variables in. Include these here.
+#--------------------------------------------------------------------
+
+AC_CONFIG_FILES([Makefile])
+#AC_CONFIG_FILES([sampleConfig.sh])
+
+#--------------------------------------------------------------------
+# Finally, substitute all of the various values into the files
+# specified with AC_CONFIG_FILES.
+#--------------------------------------------------------------------
+
+AC_OUTPUT()