summaryrefslogtreecommitdiffstats
path: root/libxslt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libxslt/Makefile.am')
-rw-r--r--libxslt/Makefile.am79
1 files changed, 79 insertions, 0 deletions
diff --git a/libxslt/Makefile.am b/libxslt/Makefile.am
new file mode 100644
index 0000000..d9fed68
--- /dev/null
+++ b/libxslt/Makefile.am
@@ -0,0 +1,79 @@
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_srcdir)/libxslt
+
+AM_CFLAGS = $(LIBXML_CFLAGS)
+
+lib_LTLIBRARIES = libxslt.la
+
+xsltincdir = $(includedir)/libxslt
+
+xsltinc_HEADERS = \
+ xslt.h \
+ xsltutils.h \
+ pattern.h \
+ templates.h \
+ variables.h \
+ keys.h \
+ numbersInternals.h \
+ extensions.h \
+ extra.h \
+ functions.h \
+ namespaces.h \
+ imports.h \
+ attributes.h \
+ documents.h \
+ preproc.h \
+ transform.h \
+ security.h \
+ xsltInternals.h \
+ xsltexports.h \
+ xsltlocale.h
+nodist_xsltinc_HEADERS = \
+ xsltconfig.h
+
+libxslt_la_SOURCES = \
+ attrvt.c \
+ xslt.c \
+ xsltlocale.c \
+ xsltutils.c \
+ pattern.c \
+ templates.c \
+ variables.c \
+ keys.c \
+ numbers.c \
+ extensions.c \
+ extra.c \
+ functions.c \
+ namespaces.c \
+ imports.c \
+ attributes.c \
+ documents.c \
+ preproc.c \
+ transform.c \
+ security.c \
+ win32config.h \
+ xsltwin32config.h.in \
+ libxslt.h
+nodist_libxslt_la_SOURCES = \
+ xsltwin32config.h
+
+if USE_VERSION_SCRIPT
+LIBXSLT_VERSION_SCRIPT = $(VERSION_SCRIPT_FLAGS)$(srcdir)/libxslt.syms
+else
+LIBXSLT_VERSION_SCRIPT =
+endif
+
+libxslt_la_LIBADD = $(LIBXML_LIBS) $(EXTRA_LIBS)
+libxslt_la_LDFLAGS = \
+ $(WIN32_EXTRA_LDFLAGS) \
+ $(LIBXSLT_VERSION_SCRIPT) \
+ -version-info $(LIBXSLT_VERSION_INFO)
+
+man_MANS = libxslt.3
+
+EXTRA_DIST = $(man_MANS) trio.h triodef.h libxslt.syms
+
+xsltproc: all
+ @(cd ../xsltproc ; $(MAKE))
+
+install-exec-hook:
+ $(MKDIR_P) "$(DESTDIR)$(libdir)/libxslt-plugins"