summaryrefslogtreecommitdiffstats
path: root/Mac/Modules/osa/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-12-09 15:06:18 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-12-09 15:06:18 (GMT)
commit2e20a63bc98da51e1e8206f55a1a519a488e2659 (patch)
treeecb58f8e7fdf1d629a6d146a7704ddb21018f461 /Mac/Modules/osa/setup.py
parent2af4ce8f3009d728d1c17758468de14920821b3d (diff)
downloadcpython-2e20a63bc98da51e1e8206f55a1a519a488e2659.zip
cpython-2e20a63bc98da51e1e8206f55a1a519a488e2659.tar.gz
cpython-2e20a63bc98da51e1e8206f55a1a519a488e2659.tar.bz2
Make this module Python 2.3 compatible, and add a setup script that allows
it to be built for that python.
Diffstat (limited to 'Mac/Modules/osa/setup.py')
-rw-r--r--Mac/Modules/osa/setup.py13
1 files changed, 13 insertions, 0 deletions
diff --git a/Mac/Modules/osa/setup.py b/Mac/Modules/osa/setup.py
new file mode 100644
index 0000000..82e7742
--- /dev/null
+++ b/Mac/Modules/osa/setup.py
@@ -0,0 +1,13 @@
+# This is a temporary setup script to allow distribution of
+# MacPython 2.4 modules for MacPython 2.3.
+
+from distutils.core import Extension, setup
+
+setup(name="OSA", version="0.1",
+ ext_modules=[
+ Extension('_OSA', ['_OSAmodule.c'],
+ extra_link_args=['-framework', 'Carbon'])
+ ],
+ py_modules=['OSA.OSA', 'OSA.OSAconst'],
+ package_dir={'OSA':'../../../Lib/plat-mac/Carbon'}
+ )