summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles-François Natali <neologix@free.fr>2013-01-08 18:51:56 (GMT)
committerCharles-François Natali <neologix@free.fr>2013-01-08 18:51:56 (GMT)
commit1aa004b45dbfb1c8512c179bd7d3a35410df8b82 (patch)
tree8a98b8e2fd5a5755f6f2dbb1601850a519fb2f30 /configure.ac
parent9a546530bb2c958c12c3724c9ac0318c3210206c (diff)
parentf6fd794fac1b6af754d233875c173afb5ca9c45e (diff)
downloadcpython-1aa004b45dbfb1c8512c179bd7d3a35410df8b82.zip
cpython-1aa004b45dbfb1c8512c179bd7d3a35410df8b82.tar.gz
cpython-1aa004b45dbfb1c8512c179bd7d3a35410df8b82.tar.bz2
Issue #16836: Enable IPv6 support even if IPv6 is disabled on the build host.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 3 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index ef58a9f..ec8f4ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2501,25 +2501,15 @@ AC_ARG_ENABLE(ipv6,
[
dnl the check does not work on cross compilation case...
- AC_RUN_IFELSE([AC_LANG_SOURCE([[ /* AF_INET6 available check */
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ /* AF_INET6 available check */
#include <sys/types.h>
-#include <sys/socket.h>
-main()
-{
- if (socket(AF_INET6, SOCK_STREAM, 0) < 0)
- exit(1);
- else
- exit(0);
-}
-]])],[
+#include <sys/socket.h>]],
+[[int domain = AF_INET6;]])],[
AC_MSG_RESULT(yes)
ipv6=yes
],[
AC_MSG_RESULT(no)
ipv6=no
-],[
- AC_MSG_RESULT(no)
- ipv6=no
])
if test "$ipv6" = "yes"; then