summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-02-16 17:57:59 (GMT)
committerGitHub <noreply@github.com>2023-02-16 17:57:59 (GMT)
commit226484e47599a93f5bf033ac47198e68ff401432 (patch)
tree466f89c4e4b7fa135d9d74f9245f29294ab9ec74 /configure.ac
parent68bd8c5e2efab64ff9d38a214775164182179431 (diff)
downloadcpython-226484e47599a93f5bf033ac47198e68ff401432.zip
cpython-226484e47599a93f5bf033ac47198e68ff401432.tar.gz
cpython-226484e47599a93f5bf033ac47198e68ff401432.tar.bz2
gh-99942: correct the pkg-config/python-config flags for cygwin/android
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 370bbe0..bc288b8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5759,7 +5759,7 @@ AC_MSG_RESULT($LDVERSION)
# On Android and Cygwin the shared libraries must be linked with libpython.
AC_SUBST(LIBPYTHON)
-if test -n "$ANDROID_API_LEVEL" -o "$MACHDEP" = "cygwin"; then
+if test "$PY_ENABLE_SHARED" = "1" && ( test -n "$ANDROID_API_LEVEL" || test "$MACHDEP" = "cygwin"); then
LIBPYTHON="-lpython${VERSION}${ABIFLAGS}"
else
LIBPYTHON=''