summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNed Deily <nad@acm.org>2012-06-25 12:04:28 (GMT)
committerNed Deily <nad@acm.org>2012-06-25 12:04:28 (GMT)
commit3784ff98114039d973d49cd3fefbb9f17360553f (patch)
treecbe798ff8921a362725ab76850f348a890b41779 /configure.ac
parent52c60979bafa70eef166661e5f58386a9d2a5498 (diff)
downloadcpython-3784ff98114039d973d49cd3fefbb9f17360553f.zip
cpython-3784ff98114039d973d49cd3fefbb9f17360553f.tar.gz
cpython-3784ff98114039d973d49cd3fefbb9f17360553f.tar.bz2
Issue #13950: Improve support for OS X Xcode 4:
Fix ./configure to provide a more sensible default for MACOSX_DEPLOYMENT_TARGET. Currently the default is the minimum OS X level that supports the universal arch option, typically 10.4, even when no universalsdk is selected. This causes various desirable features that depend on later OS X versions, like libedit readline support, to be omitted from the build. A more complete solution would take into account the SDK that is being used and better tailor the universal arch options. For now, change the existing tests to only apply to build systems of 10.5 and earlier; for 10.6 and later, use the build system version as the default deployment target if the MACOSX_DEPLOYMENT_TARGET environment variable is not provided.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a497ac8..d05e1bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1177,7 +1177,9 @@ yes)
# Calculate the right deployment target for this build.
#
cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
- if test ${cur_target} '>' 10.2; then
+ if test ${cur_target} '>' 10.2 && \
+ test ${cur_target} '<' 10.6
+ then
cur_target=10.3
if test ${enable_universalsdk}; then
if test "${UNIVERSAL_ARCHS}" = "all"; then