summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 11:48:26 (GMT)
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 11:48:26 (GMT)
commit3bfa1ed74d8bbdd2b811500fa2c6ad84c5f116df (patch)
tree8accb5566375ef844c76075febc692ce57b97c83 /configure.ac
parent8cbd3df3ce75699cdc64d0d1bd903af43da43fa0 (diff)
parent708784255e42f0946ab36d2a55e4c4ae99b086ec (diff)
downloadcpython-3bfa1ed74d8bbdd2b811500fa2c6ad84c5f116df.zip
cpython-3bfa1ed74d8bbdd2b811500fa2c6ad84c5f116df.tar.gz
cpython-3bfa1ed74d8bbdd2b811500fa2c6ad84c5f116df.tar.bz2
Issue #28538: Merge 3.6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 39273e0..cb43b28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3386,7 +3386,6 @@ AC_CHECK_FUNCS(alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
futimens futimes gai_strerror getentropy \
getgrouplist getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getresuid getresgid getpwent getspnam getspent getsid getwd \
- if_nameindex \
initgroups kill killpg lchmod lchown lockf linkat lstat lutimes mmap \
memrchr mbrtowc mkdirat mkfifo \
mkfifoat mknod mknodat mktime mremap nice openat pathconf pause pipe2 plock poll \
@@ -3739,6 +3738,19 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
AC_MSG_RESULT(no)
])
+# On Android API level 24 if_nameindex() is available, but the if_nameindex
+# structure is not defined.
+AC_MSG_CHECKING(for if_nameindex)
+AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+#ifdef HAVE_NET_IF_H
+# include <net/if.h>
+#endif
+]], [[struct if_nameindex *ni = if_nameindex(); int x = ni[0].if_index;]])],
+ [AC_DEFINE(HAVE_IF_NAMEINDEX, 1, Define to 1 if you have the 'if_nameindex' function.)
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)
+])
+
# On OSF/1 V5.1, getaddrinfo is available, but a define
# for [no]getaddrinfo in netdb.h.
AC_MSG_CHECKING(for getaddrinfo)