summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2024-06-18 17:35:44 (GMT)
committerGitHub <noreply@github.com>2024-06-18 17:35:44 (GMT)
commit49f51deeef901b677853f00e428cbaeb13ecd2f2 (patch)
tree2c8074dae55811cd6d22b437c016711bc66223a8 /configure.ac
parentc81a5e6b5b7749862d271e7a67f89976069ad2cd (diff)
downloadcpython-49f51deeef901b677853f00e428cbaeb13ecd2f2.zip
cpython-49f51deeef901b677853f00e428cbaeb13ecd2f2.tar.gz
cpython-49f51deeef901b677853f00e428cbaeb13ecd2f2.tar.bz2
gh-120688: Build WASI with -O3 in debug mode (#120691)
On WASI in debug mode, Python is now built with compiler flag -O3 instead of -Og, to support more recursive calls.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f9612b3..a469845 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2289,6 +2289,11 @@ PYDEBUG_CFLAGS="-O0"
AS_VAR_IF([ac_cv_cc_supports_og], [yes],
[PYDEBUG_CFLAGS="-Og"])
+# gh-120688: WASI uses -O3 in debug mode to support more recursive calls
+if test "$ac_sys_system" = "WASI"; then
+ PYDEBUG_CFLAGS="-O3"
+fi
+
# tweak OPT based on compiler and platform, only if the user didn't set
# it on the command line
AC_SUBST([OPT])