summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXiang Zhang <angwerzx@126.com>2018-08-20 14:36:19 (GMT)
committerGitHub <noreply@github.com>2018-08-20 14:36:19 (GMT)
commit4c8555773a801f957297132a92c0acb382d640e4 (patch)
tree6793836fe80a4cc15be8947941367f1308155ec0 /configure.ac
parent74a307d48ef8b278c4629ca0ef2139be1c9a34e6 (diff)
downloadcpython-4c8555773a801f957297132a92c0acb382d640e4.zip
cpython-4c8555773a801f957297132a92c0acb382d640e4.tar.gz
cpython-4c8555773a801f957297132a92c0acb382d640e4.tar.bz2
bpo-30411: Use --git-dir instead of -C to make git work under version below 1.8.5. (GH-8744)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 4161523..749303e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,9 +39,9 @@ HAS_GIT=no-repository
fi
if test $HAS_GIT = found
then
- GITVERSION="git -C \$(srcdir) rev-parse --short HEAD"
- GITTAG="git -C \$(srcdir) describe --all --always --dirty"
- GITBRANCH="git -C \$(srcdir) name-rev --name-only HEAD"
+ GITVERSION="git --git-dir \$(srcdir)/.git rev-parse --short HEAD"
+ GITTAG="git --git-dir \$(srcdir)/.git describe --all --always --dirty"
+ GITBRANCH="git --git-dir \$(srcdir)/.git name-rev --name-only HEAD"
else
GITVERSION=""
GITTAG=""