summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authordoko@ubuntu.com <doko@ubuntu.com>2016-06-14 06:55:19 (GMT)
committerdoko@ubuntu.com <doko@ubuntu.com>2016-06-14 06:55:19 (GMT)
commit5553231b91e05cf93827b33a79aebe62c4370a09 (patch)
tree954bd7ebb02bc705d1df336f616aedea979ea1b3 /configure.ac
parentc09087680eb908406d7331323e92a657182c7b89 (diff)
downloadcpython-5553231b91e05cf93827b33a79aebe62c4370a09.zip
cpython-5553231b91e05cf93827b33a79aebe62c4370a09.tar.gz
cpython-5553231b91e05cf93827b33a79aebe62c4370a09.tar.bz2
- Issue #23968: Rename the platform directory from plat-$(MACHDEP) to
plat-$(PLATFORM_TRIPLET). Rename the config directory (LIBPL) from config-$(LDVERSION) to config-$(LDVERSION)-$(PLATFORM_TRIPLET). Install the platform specifc _sysconfigdata module into the platform directory and rename it to include the ABIFLAGS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1fbc655..fa1bdec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -872,10 +872,17 @@ if test x$PLATFORM_TRIPLET != x && test x$MULTIARCH != x; then
AC_MSG_ERROR([internal configure error for the platform triplet, please file a bug report])
fi
fi
-PLATDIR=plat-$MACHDEP
+if test x$PLATFORM_TRIPLET = x; then
+ PLATDIR=plat-$MACHDEP
+else
+ PLATDIR=plat-$PLATFORM_TRIPLET
+fi
AC_SUBST(PLATDIR)
AC_SUBST(PLATFORM_TRIPLET)
-
+if test x$MULTIARCH != x; then
+ MULTIARCH_CPPFLAGS="-DMULTIARCH=\\\"$MULTIARCH\\\""
+fi
+AC_SUBST(MULTIARCH_CPPFLAGS)
AC_MSG_CHECKING([for -Wl,--no-as-needed])
save_LDFLAGS="$LDFLAGS"
@@ -4462,7 +4469,11 @@ AC_MSG_RESULT($LDVERSION)
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
AC_SUBST(PY_ENABLE_SHARED)
-LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
+if test x$PLATFORM_TRIPLET = x; then
+ LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
+else
+ LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
+fi
AC_SUBST(LIBPL)
# Check whether right shifting a negative integer extends the sign bit