summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2012-03-23 18:06:27 (GMT)
committerStefan Krah <skrah@bytereef.org>2012-03-23 18:06:27 (GMT)
commit60187b5ee5119094b52f11d7cdc742d1c36403ea (patch)
treef6ed3b09374028283723a844c4b5ad0bc76d5682 /configure.ac
parent0175af85a574800d8ea44e57fc9c0810edf2d0e1 (diff)
downloadcpython-60187b5ee5119094b52f11d7cdc742d1c36403ea.zip
cpython-60187b5ee5119094b52f11d7cdc742d1c36403ea.tar.gz
cpython-60187b5ee5119094b52f11d7cdc742d1c36403ea.tar.bz2
Issue #7652: Enable linking of _decimal.so against an installed libmpdec.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78bcbe7..f1197b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2048,6 +2048,15 @@ AC_SUBST(LIBFFI_INCLUDEDIR)
AC_MSG_RESULT($with_system_ffi)
+# Check for use of the system libmpdec library
+AC_MSG_CHECKING(for --with-system-libmpdec)
+AC_ARG_WITH(system_libmpdec,
+ AS_HELP_STRING([--with-system-libmpdec], [build _decimal module using an installed libmpdec library]),
+ [],
+ [with_system_libmpdec="no"])
+
+AC_MSG_RESULT($with_system_libmpdec)
+
# Check for support for loadable sqlite extensions
AC_MSG_CHECKING(for --enable-loadable-sqlite-extensions)
AC_ARG_ENABLE(loadable-sqlite-extensions,