summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@python.org>2023-05-24 20:34:41 (GMT)
committerGitHub <noreply@github.com>2023-05-24 20:34:41 (GMT)
commit684e99d01df0c7c8f7c67567e2cece4673df9432 (patch)
treece4e099967cd12b76e38518fe36942783a57ebe0 /configure.ac
parent160321e5304b962a162eb023472aa2bc8307ae15 (diff)
downloadcpython-684e99d01df0c7c8f7c67567e2cece4673df9432.zip
cpython-684e99d01df0c7c8f7c67567e2cece4673df9432.tar.gz
cpython-684e99d01df0c7c8f7c67567e2cece4673df9432.tar.bz2
gh-104773: PEP 594: Remove the spwd module (#104871)
Remove spwd from the configure script and Modules/Setup.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index e3c7662..325df16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7082,15 +7082,13 @@ AC_DEFUN([PY_STDLIB_MOD_SET_NA], [
# stdlib not available
dnl Modules that are not available on some platforms
-dnl AIX has shadow passwords, but access is not via getspent()
dnl VxWorks does not provide crypt() function
AS_CASE([$ac_sys_system],
- [AIX], [PY_STDLIB_MOD_SET_NA([_scproxy], [spwd])],
+ [AIX], [PY_STDLIB_MOD_SET_NA([_scproxy])],
[VxWorks*], [PY_STDLIB_MOD_SET_NA([_scproxy], [_crypt], [termios], [grp])],
- [Darwin], [PY_STDLIB_MOD_SET_NA([spwd])],
[CYGWIN*], [PY_STDLIB_MOD_SET_NA([_scproxy], [nis])],
[QNX*], [PY_STDLIB_MOD_SET_NA([_scproxy], [nis])],
- [FreeBSD*], [PY_STDLIB_MOD_SET_NA([_scproxy], [spwd])],
+ [FreeBSD*], [PY_STDLIB_MOD_SET_NA([_scproxy])],
[Emscripten|WASI], [
dnl subprocess and multiprocessing are not supported (no fork syscall).
dnl curses and tkinter user interface are not available.
@@ -7113,7 +7111,6 @@ AS_CASE([$ac_sys_system],
[nis],
[pwd],
[resource],
- [spwd],
[syslog],
)
AS_CASE([$ac_sys_system/$ac_sys_emscripten_target],
@@ -7264,7 +7261,6 @@ PY_STDLIB_MOD([resource], [], [test "$ac_cv_header_sys_resource_h" = yes])
PY_STDLIB_MOD([_scproxy],
[test "$ac_sys_system" = "Darwin"], [],
[], [-framework SystemConfiguration -framework CoreFoundation])
-PY_STDLIB_MOD([spwd], [], [test "$ac_cv_func_getspent" = yes -o "$ac_cv_func_getspnam" = yes])
PY_STDLIB_MOD([syslog], [], [test "$ac_cv_header_syslog_h" = yes])
PY_STDLIB_MOD([termios], [], [test "$ac_cv_header_termios_h" = yes])